using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\""compliantNotes\"": \"").*(?=\""\s+\""compliantDetected\"":)";
string input = @"""compliantNotes"": "" this is
the text I expect, works in Chrome, but not in IE"" ""compliantDetected"": blah
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}