$re = '/(?<!\d\s)(?<!\d)(mil)\b/m';
$str = 'esta a mil o a 25 mil 500 millas de la ciudad de milan
mil o mas para pasar! y tu tienes menos de mil
hace casi mil o 2mil anos aparecio un fenomeno legendario tan solo a millas de aqui';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);