#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http[s]?:\/\/)?(www.)?(11st|auction|bj\.afreecatv|blog\.naver|blog\.daum|cafe\.daum|cafe\.naver|smartstore\.naver|storefarm\.naver|partner\.booking.naver\.com|partner\.booking\=.naver|shop\.naver\.com|gmarket|go\.kr).*"
Local $sString = "http://11st.co.kr" & @CRLF & _
"http://www.11st.co.kr" & @CRLF & _
"http://auction.co.kr" & @CRLF & _
"http://blog.naver.com/wef" & @CRLF & _
"http://blog.daum.net/wef" & @CRLF & _
"http://bj.afreecatv.com/wef" & @CRLF & _
"http://cafe.daum.net" & @CRLF & _
"http://cafe.naver.com/" & @CRLF & _
"http://smartstore.naver.com" & @CRLF & _
"http://smartstore.naver.com/wef" & @CRLF & _
"storefarm.naver.com" & @CRLF & _
"http://partner.booking.naver.com/bizes" & @CRLF & _
"http://shop.naver.com/starkrobotics" & @CRLF & _
"http://sell.storefarm.naver.com" & @CRLF & _
"https://www.rndia.or.kr/" & @CRLF & _
"http://m.hakjum.com/" & @CRLF & _
"itskorea.kr" & @CRLF & _
"minishop.gmarket.co.kr" & @CRLF & _
"hrd.keia.kr" & @CRLF & _
"www.dsf.go.kr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")