$re = '/(\d{1,2})\s([a-z]{3})\.?\s(\d{1,2}:\d{1,2})\s-\s([a-z]+):\s(.+)/i';
$str = '11 jan. 22:20 - Dam: Ik zal d\'r zijn';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);