package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\$\{(?P<braced>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z][_a-zA-Z0-9]*)+)\})|(?:\$(?P<named>[_a-zA-Z][a-zA-Z0-9]*(?::[_a-zA-Z][_a-zA-Z0-9]*)+))`)
var str = `asdasd $asd:sd + ${asd123:asd} $HOME $$asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}