use strict;
my $str = 'arg1=ABC arg2=123 arg3= arg4="consecutive spaces and \\"escaped quote\\" shall be preserved within quotes"';
my $regex = qr/"[^"\\]*(?:\\.[^"\\]*)*"(*SKIP)(*F)|\h+/mp;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";