$re = '/^(?:locality|suburb)(?:(?:-|_)?name)?$/im';
$str = 'locality
Locality
LocalityName
locality_name
locality-name
suburb
Suburb
SuburbName
suburb_name
suburb-name
locality_pid
locality_index
LocalityRef
street_locality_pid
street_suburb_pid
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);