// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0|[1-8]\d?|90?)(?:\.\d+)?$").unwrap();
let string = "91
90
90.45
90.9999
0
0.23
9
80
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}