$re = '/subrackNo=(?P<name1>\d+).*boardType=(?P<name3>\w+).*SlotNo=(?P<name2>\d+).* /';
$str = '2016-12-18 23:59:59,DeviceName=Device1,subrackNo=2,boardType=GOUc,SlotNo=23,SubsystemNo=1,CPUoccupancy=3,Throughputoccupancy=0
2016-12-18 23:59:59,DeviceName=Device1,subrackNo=2,boardType=GOUd,SlotNo=24,SubsystemNo=1,CPUoccupancy=3,Throughputoccupancy=0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);