package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`age\s[a-z]+:\s*\d+\s*(-\s*\d+\s*(years?|months?|yrs)/\d+\s*)+years and up`)
var str = `age: adult/child gender: male/female age range: 3 - 5 years/5 - 8 years/8 - 12 years/12 years and up product type: costume character: animals & insects material: polyester theme: animal age start: 3 years age end: adult features: -face is seen through the mouth of the zebra. -zipper closure in the front and a tail in the back. -set includes: jumpsuit and head mask. -animal collection. age: -adult/child. gender: -male/female. age range: -3 - 5 years/5 - 8 years/8 - 12 years/12 years and up
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}