// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+[0-9]{2}[.\-\s]?|00[.\-\s]?[0-9]{2}|0)([0-9]{1,3}[.\-\s]?(?:[0-9]{2}[.\-\s]?){4})$").unwrap();
let string = "0512345678
05 12 34 56 78
05.12.34.56.78
05-12-34-56-78
+33621325465
+336 21 32 54 65
+336.21.32.54.65
+336-21-32-54-65
0033621325465
00336 21 32 54 65
00336.21.32.54.65
00336-21-32-54-65";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}