package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})([0-9a-fA-F]{2})`)
var str = `00010203
01010203
0C0D0E0F`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}