package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\Bis\B`)
var str = `This island is not an aisle`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}