using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# single line demo (do not use multiline input for testing this)
^(?=\D*\d)(?=[^\W_]*[\W_])(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])\S{8,}$";
string input = @"FooBar1$";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}