#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<!\d)\d{4}-\d{2}-\d{2}(?!\d)"
Local $sString = "1111-11-34" & @CRLF & _
"5551111-11-11" & @CRLF & _
"abcd1234-11-11-whatever" & @CRLF & _
"abcsgadg1234-22-33666" & @CRLF & _
"att_token_2015-09-02" & @CRLF & _
"att_token_1234-99-99" & @CRLF & _
"att_token_1234" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")