using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/(?:[^\/\n]*\.)*google\.com(?:\/[^\n]*)?$";
string input = @"http://test.google.com/
http://google.com/
http://test.google.com
http://.google.com/
http://one.more.test.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}