$re = '/^http:\/\/(?:[^\/\n]*\.)*google\.com(?:\/[^\n]*)?$/m';
$str = 'http://test.google.com/
http://google.com/
http://test.google.com
http://.google.com/
http://one.more.test.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);