# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\n\r:]*)(:[ \t])[ \t]*([^\n\r]*)"
test_str = ("NetRange: 2001:4860:: - 2001:4860:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF\n"
"CIDR: 2001:4860::/32\n"
"NetName: GOOGLE-IPV6\n"
"NetHandle: NET6-2001-4860-1\n"
"Parent: ARIN-004 (NET6-2001-4800-0)\n"
"NetType: Direct Allocation\n"
"OriginAS: AS15169\n"
"Organization: Google LLC (GOGL)\n"
"RegDate: 2005-03-14\n"
"Updated: 2012-02-24\n"
"Ref: https://rdap.arin.net/registry/ip/2001:4860::\n\n"
"OrgName: Google LLC\n"
"OrgId: GOGL\n"
"Address: 1600 Amphitheatre Parkway\n"
"City: Mountain View\n"
"StateProv: CA\n"
"PostalCode: 94043\n"
"Country: US\n"
"RegDate: 2000-03-30\n"
"Updated: 2019-10-31\n"
"Comment: Please note that the recommended way to file abuse complaints are located in the following links. \n"
"Comment: \n"
"Comment: To report abuse and illegal activity: https://www.google.com/contact/\n"
"Comment: \n"
"Comment: For legal requests: http://support.google.com/legal \n"
"Comment: \n"
"Comment: Regards, \n"
"Comment: The Google Team\n"
"Ref: https://rdap.arin.net/registry/entity/GOGL\n\n"
"OrgTechHandle: ZG39-ARIN\n"
"OrgTechName: Google LLC\n"
"OrgTechPhone: +1-650-253-0000 \n"
"OrgTechEmail: arin-contact@google.com\n"
"OrgTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
"OrgAbuseHandle: ABUSE5250-ARIN\n"
"OrgAbuseName: Abuse\n"
"OrgAbusePhone: +1-650-253-0000 \n"
"OrgAbuseEmail: network-abuse@google.com\n"
"OrgAbuseRef: https://rdap.arin.net/registry/entity/ABUSE5250-ARIN\n"
"RNOCHandle: ZG39-ARIN\n"
"RNOCName: Google LLC\n"
"RNOCPhone: +1-650-253-0000 \n"
"RNOCEmail: arin-contact@google.com\n"
"RNOCRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
"RTechHandle: ZG39-ARIN\n"
"RTechName: Google LLC\n"
"RTechPhone: +1-650-253-0000 \n"
"RTechEmail: arin-contact@google.com\n"
"RTechRef: https://rdap.arin.net/registry/entity/ZG39-ARIN\n"
"RAbuseHandle: ZG39-ARIN\n"
"RAbuseName: Google LLC\n"
"RAbusePhone: +1-650-253-0000 \n"
"RAbuseEmail: arin-contact@google.com\n"
"RAbuseRef: https://rdap.arin.net/registry/entity/ZG39-ARIN")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.