using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b>(?:(?!<\/b>).)*<b>";
string input = @"This is some <b>correct</b> formatting
This is some <b>incorrect<b> formatting";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}