re = /<b>(?:(?!<\/b>).)*<b>/m
str = 'This is some <b>correct</b> formatting
This is some <b>incorrect<b> formatting'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end