using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Carrier )?Tracking Number\s*:?\s*([A-Z0-9]+)";
string input = @"Tracking Number
1ZA828Y12313205351
Carrier Tracking Number : 582612345988";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}