package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:Carrier )?Tracking Number\s*:?\s*([A-Z0-9]+)`)
var str = `Tracking Number
1ZA828Y12313205351
Carrier Tracking Number : 582612345988`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}