re = /(?:Carrier )?Tracking Number\s*:?\s*([A-Z0-9]+)/m
str = 'Tracking Number
1ZA828Y12313205351
Carrier Tracking Number : 582612345988'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end