$re = '/([abc])(?!\1)([abc])(?!\2|\1)[abc]/';
$str = 'adesfecabefgswaswabdcbaes';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);