$re = '/^[A-Za-z0-9~!#$%^&*()_+=\-`|\\\\\/\[\];,{}"\']+[A-Za-z0-9~!#$%^&:* ()_+=\-`|\\\\\/\[\].;,{}"\']+@[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\\\/\[\].;,{}"\']+@{0,1}[A-Za-z0-9~!#$%^&:*()_+=\-`|\\\\\/\[\].;,{}"\']+[A-Za-z0-9\]]$/';
$str = 'vigan@[IPv6:2001:db8::1]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);