re = /https:\/\/(?:.*?\.)?domain\.com.*/m
str = 'https://domain.com
https://domain.com/test/123.pdf
https://www.domain.com
https://testabc.domain.com
https://test.abc.domain.com
http://domain.com
https://www.domaaaain.com
https://www.domaaaain.com/test/abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end