# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)\s+(?=\d)/$1/g;t' <<< "The store is 5 6 7 8"