use strict;
my $str = 'The store is 5 6 7 8';
my $regex = qr/(\d)\s+(?=\d)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";