$re = '/(\d)\s+(?=\d)/';
$str = 'The store is 5 6 7 8';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;