import Foundation
let pattern = #"(\d)\s+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The store is 5 6 7 8"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)