#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([^+>]*)[^<]*(<a [^>]*(href="([^>^\"]*)")[^>]*>)([^<]+)(<\/a>)"
Local $sString = "This is <a target="_blank" href="www.google.com?Test=t+1">test</a> a rabbit" & @CRLF & _
"My second sentence <a href="www.msn.co.uk">test 2</a> is here dfdfdf." & @CRLF & _
"Third sentence <a href="www.yahoo.co.uk" target="_blank">test 3</a> a rabbitdddd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")