// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)([^+>]*)[^<]*(<a [^>]*(href="([^>^\"]*)")[^>]*>)([^<]+)(<\/a>)"#).unwrap();
let string = "This is <a target=\"_blank\" href=\"www.google.com?Test=t+1\">test</a> a rabbit
My second sentence <a href=\"www.msn.co.uk\">test 2</a> is here dfdfdf.
Third sentence <a href=\"www.yahoo.co.uk\" target=\"_blank\">test 3</a> a rabbitdddd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}