$re = '%<a[^>]*?~dead host~.*?</a>%i';
$str = 'There is a bunch of text here. It sure is a pretty day outside. <a href=\'http://~dead host~/vypdye57f25o\' rel=\'nofollow\' target=\'blank\'>part-2</a> The sun is chirping, the birds are shining. It\'s a glorious day today, indeed.
There once was a man from Nantucket, who kept all his cash in a bucket. <a href="http://www.google.com">Google.com</a> But his daughter named "Nan" ran away with a man and as for the bucket, Nan tuck it. <a href="http://~dead host~/asdf">Dead host</a>. Paw followed this pair to Nantucket, the mand and the girl with the bucket, and he said to the man, "You\'re welcome to Nan", but as for the bucket, Paw tuck it. <a href="http://www.yahoo.com">asdf</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);