#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([^ >]+).*<\/\1>"
Local $sString = "<paper-input label="Input label"> Some text </paper-input>" & @CRLF & _
"<paper-input label="Input label"> Some text </paper-inputa>" & @CRLF & _
"<azz> Some text </az>" & @CRLF & _
"<az> Some text </az>" & @CRLF & _
"<az> Some text </aza>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")