const regex = /^(\d+)\.+\d+\.(\d+)\.+\d+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\.+\\d+\\.(\\d+)\\.+\\d+$', 'g')
const str = `16.0.8730.1000
17.2.444444.1
16.0.1000
16.0.1000.0.0
16.0.1000.0a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}