import Foundation
let pattern = #"(?:(un|deux|trois|quatre|cinq|six|sept|huit|neuf|dix|quinze|vingt|trente)\s+(mois|années|année|ans|an)\s+(?:d'(emprisonnement)|de (réclusion criminelle)))|(?:de\s+la\s+(réclusion)\s+criminelle\s+à\s+(perpétuité))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Le vol est puni de la réclusion criminelle à perpétuité et de 150 000 euros d'amende lorsqu'il est précédé, accompagné ou suivi soit de violences ayant entraîné la mort, soit de tortures ou d'actes de barbarie. "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)