#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div class="img-with-caption".*url\((.*)\)"
Local $sString = "<div class="article-text">" & @CRLF & _
" <p>Some text with <a href="/www.example.com/articles/49135" target="_blank">link</a>. </p>" & @CRLF & _
" <p>Some other text</p>" & @CRLF & _
" <div class="post-slideshow js-slider" style="overflow: hidden; visibility: visible;">" & @CRLF & _
" <div style="list-style: none; margin: 0px; width: 1710px; transition: 0ms; -webkit-transition: 0ms; -webkit-transform: translate3d(0px, 0px, 0px);">" & @CRLF & _
" <div style="display: table-cell; width: 285px; vertical-align: top;">" & @CRLF & _
" <div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/2T30WPIWIUV1OUokYrlIbQ-small.jpg)"></div>" & @CRLF & _
" <div class="slide-caption"><span class="text"></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div style="display: table-cell; width: 285px; vertical-align: top;">" & @CRLF & _
" <div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/oWdXjCe7bnoUtGyqnlggBA-small.jpg)"></div>" & @CRLF & _
" <div class="slide-caption"><span class="text"></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <!-- more images here -->" & @CRLF & _
" <div class="custom_slide" style="display: table-cell; width: 285px; vertical-align: top;"></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="slideshow-counter"><span class="current">1</span> / <span class="total">5</span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <p class="small sasha-text"><strong>Images:</strong> «<a href="/www.example.com/" target="_blank">Example Studio</a>»</p>" & @CRLF & _
" <p>Some other text.</p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")