package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`<div class="img-with-caption".*url\((.*)\)`)
    var str = `<div class="article-text">
    <p>Some text with <a href="/www.example.com/articles/49135" target="_blank">link</a>. </p>
    <p>Some other text</p>
    <div class="post-slideshow js-slider" style="overflow: hidden; visibility: visible;">
        <div style="list-style: none; margin: 0px; width: 1710px; transition: 0ms; -webkit-transition: 0ms; -webkit-transform: translate3d(0px, 0px, 0px);">
            <div style="display: table-cell; width: 285px; vertical-align: top;">
                <div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/2T30WPIWIUV1OUokYrlIbQ-small.jpg)"></div>
                <div class="slide-caption"><span class="text"></span>
                </div>
            </div>
            <div style="display: table-cell; width: 285px; vertical-align: top;">
                <div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/oWdXjCe7bnoUtGyqnlggBA-small.jpg)"></div>
                <div class="slide-caption"><span class="text"></span>
                </div>
            </div>
            <!-- more images here -->
            <div class="custom_slide" style="display: table-cell; width: 285px; vertical-align: top;"></div>
        </div>
        <div class="slideshow-counter"><span class="current">1</span> / <span class="total">5</span>
        </div>
    </div>
    <p class="small sasha-text"><strong>Images:</strong> Â«<a href="/www.example.com/" target="_blank">Example Studio</a>»</p>
    <p>Some other text.</p>
</div>`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}