import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"img-with-caption\".*url\\((.*)\\)";
final String string = "<div class=\"article-text\">\n"
+ " <p>Some text with <a href=\"/www.example.com/articles/49135\" target=\"_blank\">link</a>. </p>\n"
+ " <p>Some other text</p>\n"
+ " <div class=\"post-slideshow js-slider\" style=\"overflow: hidden; visibility: visible;\">\n"
+ " <div style=\"list-style: none; margin: 0px; width: 1710px; transition: 0ms; -webkit-transition: 0ms; -webkit-transform: translate3d(0px, 0px, 0px);\">\n"
+ " <div style=\"display: table-cell; width: 285px; vertical-align: top;\">\n"
+ " <div class=\"img-with-caption\" style=\"background-image: url(/lamcdn.net/example.com/post_image-image/2T30WPIWIUV1OUokYrlIbQ-small.jpg)\"></div>\n"
+ " <div class=\"slide-caption\"><span class=\"text\"></span>\n"
+ " </div>\n"
+ " </div>\n"
+ " <div style=\"display: table-cell; width: 285px; vertical-align: top;\">\n"
+ " <div class=\"img-with-caption\" style=\"background-image: url(/lamcdn.net/example.com/post_image-image/oWdXjCe7bnoUtGyqnlggBA-small.jpg)\"></div>\n"
+ " <div class=\"slide-caption\"><span class=\"text\"></span>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- more images here -->\n"
+ " <div class=\"custom_slide\" style=\"display: table-cell; width: 285px; vertical-align: top;\"></div>\n"
+ " </div>\n"
+ " <div class=\"slideshow-counter\"><span class=\"current\">1</span> / <span class=\"total\">5</span>\n"
+ " </div>\n"
+ " </div>\n"
+ " <p class=\"small sasha-text\"><strong>Images:</strong> «<a href=\"/www.example.com/\" target=\"_blank\">Example Studio</a>»</p>\n"
+ " <p>Some other text.</p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}