const regex = /<div class="img-with-caption".*url\((.*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="img-with-caption".*url\\((.*)\\)', 'g')
const str = `<div class="article-text">
<p>Some text with <a href="/www.example.com/articles/49135" target="_blank">link</a>. </p>
<p>Some other text</p>
<div class="post-slideshow js-slider" style="overflow: hidden; visibility: visible;">
<div style="list-style: none; margin: 0px; width: 1710px; transition: 0ms; -webkit-transition: 0ms; -webkit-transform: translate3d(0px, 0px, 0px);">
<div style="display: table-cell; width: 285px; vertical-align: top;">
<div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/2T30WPIWIUV1OUokYrlIbQ-small.jpg)"></div>
<div class="slide-caption"><span class="text"></span>
</div>
</div>
<div style="display: table-cell; width: 285px; vertical-align: top;">
<div class="img-with-caption" style="background-image: url(/lamcdn.net/example.com/post_image-image/oWdXjCe7bnoUtGyqnlggBA-small.jpg)"></div>
<div class="slide-caption"><span class="text"></span>
</div>
</div>
<!-- more images here -->
<div class="custom_slide" style="display: table-cell; width: 285px; vertical-align: top;"></div>
</div>
<div class="slideshow-counter"><span class="current">1</span> / <span class="total">5</span>
</div>
</div>
<p class="small sasha-text"><strong>Images:</strong> «<a href="/www.example.com/" target="_blank">Example Studio</a>»</p>
<p>Some other text.</p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}