# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"img-with-caption\".*url\((.*)\)"
test_str = ("<div class=\"article-text\">\n"
" <p>Some text with <a href=\"/www.example.com/articles/49135\" target=\"_blank\">link</a>. </p>\n"
" <p>Some other text</p>\n"
" <div class=\"post-slideshow js-slider\" style=\"overflow: hidden; visibility: visible;\">\n"
" <div style=\"list-style: none; margin: 0px; width: 1710px; transition: 0ms; -webkit-transition: 0ms; -webkit-transform: translate3d(0px, 0px, 0px);\">\n"
" <div style=\"display: table-cell; width: 285px; vertical-align: top;\">\n"
" <div class=\"img-with-caption\" style=\"background-image: url(/lamcdn.net/example.com/post_image-image/2T30WPIWIUV1OUokYrlIbQ-small.jpg)\"></div>\n"
" <div class=\"slide-caption\"><span class=\"text\"></span>\n"
" </div>\n"
" </div>\n"
" <div style=\"display: table-cell; width: 285px; vertical-align: top;\">\n"
" <div class=\"img-with-caption\" style=\"background-image: url(/lamcdn.net/example.com/post_image-image/oWdXjCe7bnoUtGyqnlggBA-small.jpg)\"></div>\n"
" <div class=\"slide-caption\"><span class=\"text\"></span>\n"
" </div>\n"
" </div>\n"
" <!-- more images here -->\n"
" <div class=\"custom_slide\" style=\"display: table-cell; width: 285px; vertical-align: top;\"></div>\n"
" </div>\n"
" <div class=\"slideshow-counter\"><span class=\"current\">1</span> / <span class=\"total\">5</span>\n"
" </div>\n"
" </div>\n"
" <p class=\"small sasha-text\"><strong>Images:</strong> «<a href=\"/www.example.com/\" target=\"_blank\">Example Studio</a>»</p>\n"
" <p>Some other text.</p>\n"
"</div>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.