# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=&m).*?(?=(?:\*\*|\*|__|~~)*(?:&r|$)))"
test_str = ("plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain\n\n"
"plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain\n\n"
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&oitalic &r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain\n\n"
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&nunderline &r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain\n\n"
"plain &kobfuscated &r&l**bold **&r&mstrikethrough &r&n__underline __&r&o*italic *&r&l**&mbold-strikethrough **&r&l**bold &mbold-strikethrough **&rplain\n\n"
"plain &kobfuscated &r&l**bold **&r&m~~strikethrough ~~&r&n__underline __&r&o*italic *&r&l**&m~~bold-strikethrough ~~**&r&l**bold &m~~bold-strikethrough ~~**&rplain\n\n"
"plain obfuscated **bold **~~strikethrough ~~__underline __*italic ***~~bold-strikethrough ~~****bold ~~bold-strikethrough ~~**plain")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.