re = /(?:\G(?!^)|^pub-\d{5}(?=\d*$))\K\d(?=\d{5})/m
str = 'pub-1885335825402893'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result