$re = '/([\w\W]*)<FooBar>/m';
$str = 'abcde
fghij<FooBar>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);