import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.+?)(?<!(?<!\\\\)\\\\{2})\\]";
final String string = "+------------------+----------------+\n"
+ "| Input | Output |\n"
+ "+------------------+----------------+\n"
+ "| [B] | B |\n"
+ "| [B][C][D] | B |\n"
+ "| [hello\\t\\tworld] | hello\\t\\tworld |\n"
+ "| [hello\\n\\nworld] | hello\\n\\nworld |\n"
+ "| [\\\\]] | \\\\] |\n"
+ "| [\\\\\\\\] | \\\\\\\\ |\n"
+ "| [x[y\\\\]z][foo] | x[y\\\\]z |\n"
+ "+------------------+----------------+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}