const regex = /^193\.172\.166\.([1-2][0-9]|3[0-1]|[0-9])$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^193\\.172\\.166\\.([1-2][0-9]|3[0-1]|[0-9])$', 'gmi')
const str = `193.172.166.0
193.172.166.9
193.172.166.11
193.172.166.31
193.172.166.32
193.172.166.45
193.172.166.100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}