import re
regex = re.compile(r"^..(.[!G)(3w^]|.{7}$|$)|\$\?", flags=re.MULTILINE)
test_str = ("The next answer has to match the following strings:\n\n"
"PPCG\n"
"^P\n"
"^[P^]P\n"
"[^?][PG]$\n"
"(?<!\\\\..)(?!]).$\n"
"^[\\w^]*$|!|]P|G]\\$$\n"
"!|[^?]P(CG|G..)?$\n"
"[^])]\\$|^\\^?P|P.\\].$\n"
"([.$?]|G\\])\\$$|^\\^?P|\\]P$\n"
"([P.$?]\\$|[]^]P|G\\]\\$|CG)$\n"
"!|((G.|P|\\.)\\$|[^?]P|CG)$\n"
"^[(!P]|G..$|]..\\||[^?]P$\n"
"^.{3,23}[.-~]..\\$$|[^P?][PG]$\n\n"
"And fail on these strings:\n\n"
"[PPCG]\n"
"^[P\\^]\n"
"[^\\]]$\n"
"^\\^?P\n"
"[^?][PG]$|<|PG\n"
"^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$\n"
"^(.{,4}|.{9}|.{16,19}|.{5}P)$\n"
"^[^?]*[PG]$|[?$].*\\$$\n"
"^[^[]P|]P|(G]|[.])\\$$\n"
"\\..$|!|\\|G|^[\\^P]P|P\\^|G.\\$$\n"
"...\\^.P|^!|G]\\$$|w|<!|^\\^?P\n"
"([^\\\\}<]{3}|][^]]|^).?[$PG]$\n"
"^(..[^^].{4,22}\\$|[^?]+\\w)$|2\n"
"^(..[^^].{4,22}\\$|[^?]+\\w)$|~")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")