re = /^\D*([\d ,]+)\s*(.*)$/m
str = '220-224 (Even) roadname1
site of 5 to 9 (odd) roadname2
16, 19 roadname3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end